summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 50afd4f..7923279 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -14,17 +14,19 @@
# implied. See the License for the specific language governing
# permissions and limitations under the License.
-noinst_DATA = README.html README
-EXTRA_DIST = $(noinst_DATA) style.css README.html.in
+noinst_DATA = README.html
-MAINTAINERCLEANFILES = README README.html
+MAINTAINERCLEANFILES = README.html
CLEANFILES =
if USE_LYNX
+noinst_DATA += README
+MAINTAINERCLEANFILES += README
+CLEANFILES += README
+
README: README.html
lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' > $@
-CLEANFILES += README
endif
tidy: README.html
@@ -32,3 +34,5 @@ tidy: README.html
.PHONY: tidy
+EXTRA_DIST = $(noinst_DATA) style.css README.html.in
+