summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-06-05 20:14:45 +0000
committerLennart Poettering <lennart@poettering.net>2005-06-05 20:14:45 +0000
commitb2972e79c5d11dfa0625bf43838cb65209f7e632 (patch)
treeee45296a668255b7ad63dfc0e0963209a7299093 /src/Makefile.am
parent37621a019f8fb5e0ac2e506b45279ab7ba67a167 (diff)
* cleanup trash recursively
* ignore some more files * compile as C99 with -pedantic * upgrade to Berkeley DB 4.3 * add some tests for rm_rf() and copy_fd() * remove some minor warnings * minor fixes git-svn-id: file:///home/lennart/svn/public/syrep/trunk@76 07ea20a6-d2c5-0310-9e02-9ef735347d72
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fb877d3..d3911b1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,8 +16,11 @@
# along with syrep; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+AM_CPPFLAGS=-I../lib -D_GNU_SOURCE
+
bin_PROGRAMS = syrep
-AM_CPPFLAGS=-I../lib
+
+noinst_PROGRAMS = rm-rf-test copy-fd-test
syrep_SOURCES = cache.c cache.h \
update.c update.h \
@@ -43,6 +46,9 @@ syrep_SOURCES = cache.c cache.h \
forget.c forget.h
syrep_LDADD=@LIBOBJS@
+rm_rf_test_SOURCES = util.c rm-rf-test.c util.h cmdline.c cmdline.h
+copy_fd_test_SOURCES = util.c copy-fd-test.c util.h cmdline.c cmdline.h
+
EXTRA_DIST = syrep.ggo getopt.c getopt1.c mkdtemp.c
MAINTAINERCLEANFILES =
BUILT_SOURCES =