summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fb877d3..d3911b1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,8 +16,11 @@
# along with syrep; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+AM_CPPFLAGS=-I../lib -D_GNU_SOURCE
+
bin_PROGRAMS = syrep
-AM_CPPFLAGS=-I../lib
+
+noinst_PROGRAMS = rm-rf-test copy-fd-test
syrep_SOURCES = cache.c cache.h \
update.c update.h \
@@ -43,6 +46,9 @@ syrep_SOURCES = cache.c cache.h \
forget.c forget.h
syrep_LDADD=@LIBOBJS@
+rm_rf_test_SOURCES = util.c rm-rf-test.c util.h cmdline.c cmdline.h
+copy_fd_test_SOURCES = util.c copy-fd-test.c util.h cmdline.c cmdline.h
+
EXTRA_DIST = syrep.ggo getopt.c getopt1.c mkdtemp.c
MAINTAINERCLEANFILES =
BUILT_SOURCES =