summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <jmccann@redhat.com>2008-02-11 12:33:16 -0500
committerWilliam Jon McCann <jmccann@redhat.com>2008-02-11 12:33:16 -0500
commit3f178c6d15daed161fe3bd7f5d9019a592cc564a (patch)
treeff8ed4e6a40987ca8d6265efe0c51df6be03fd80 /tools/Makefile.am
parent710a4f5404049762ea49644c74aadb59737be37d (diff)
add tools to log restart and stop events
This should probably be used by init instead of logging the event from CK.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index bf6a4ae..1fe0f6b 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -50,6 +50,8 @@ bin_PROGRAMS = \
sbin_PROGRAMS = \
ck-log-system-start \
+ ck-log-system-restart \
+ ck-log-system-stop \
$(NULL)
ck_list_sessions_SOURCES = \
@@ -79,6 +81,24 @@ ck_log_system_start_LDADD = \
$(top_builddir)/src/libck-event-log.la \
$(NULL)
+ck_log_system_restart_SOURCES = \
+ ck-log-system-restart.c \
+ $(NULL)
+
+ck_log_system_restart_LDADD = \
+ $(HISTORY_LIBS) \
+ $(top_builddir)/src/libck-event-log.la \
+ $(NULL)
+
+ck_log_system_stop_SOURCES = \
+ ck-log-system-stop.c \
+ $(NULL)
+
+ck_log_system_stop_LDADD = \
+ $(HISTORY_LIBS) \
+ $(top_builddir)/src/libck-event-log.la \
+ $(NULL)
+
libexec_PROGRAMS = \
ck-collect-session-info \
ck-get-x11-server-pid \