summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-05-09 08:39:26 +0000
committerPierre Ossman <ossman@cendio.se>2006-05-09 08:39:26 +0000
commit4e71f20d6cecff245a45233d4953beb4e0b29178 (patch)
tree05f495bfd81e0120cd84f47f7e77a87522bf56bd /src/Makefile.am
parent06e1867307777ffa8686762ff3e42143d88b46ed (diff)
Add stubs for the threaded main loop so that we can compile it on
non-supported platforms (still can't run it though). git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@834 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 66e20af5..ee7b2325 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -188,7 +188,8 @@ noinst_PROGRAMS = \
voltest \
memblockq-test \
sync-playback \
- channelmap-test
+ channelmap-test \
+ thread-mainloop-test
if HAVE_SIGXCPU
noinst_PROGRAMS += \
@@ -206,12 +207,6 @@ noinst_PROGRAMS += \
mainloop-test-glib12
endif
-# FIXME: We need to make thread-mainloop win32-compatible first
-if !OS_IS_WIN32
-noinst_PROGRAMS += \
- thread-mainloop-test
-endif
-
mainloop_test_SOURCES = tests/mainloop-test.c
mainloop_test_CFLAGS = $(AM_CFLAGS)
mainloop_test_LDADD = $(AM_LDADD) libpolyp-@PA_MAJORMINOR@.la